nix-conf/modules/servers/thor/changedetection-io.nix

25 lines
576 B
Nix

{...}: {
services.changedetection-io = {
enable = true;
playwrightSupport = true;
baseURL = "https://changedetection.cronyakatsuki.xyz";
behindProxy = true;
};
services.traefik.dynamicConfigOptions.http = {
services.changedetection.loadBalancer.servers = [
{
url = "http://localhost:5000";
}
];
routers.changedetection = {
rule = "Host(`changedetection.cronyakatsuki.xyz`)";
tls = {
certResolver = "porkbun";
};
service = "changedetection";
entrypoints = "websecure";
};
};
}